The query systems have recovered. We are monitoring the systems to make sure it is stable.
Posted Jul 24, 2026 - 20:14 PDT
Monitoring
We have identified the root cause. The system is recovering. We are closely monitoring to make sure it continues to remain stable.
Posted Jul 24, 2026 - 20:07 PDT
Identified
Queries for recent data are currently degraded, which is also affecting our alerting system. We're working to stabilize the system as our highest priority.
Posted Jul 24, 2026 - 19:39 PDT
Update
We are continuing to investigate this issue.
Posted Jul 24, 2026 - 19:11 PDT
Investigating
We have detected an issue in querying metrics in US 1 region. We are currently investigating the issue and will share updates as our investigation progresses.